What’s Vulnerable › Vulnerabilities
CVE-2022-4140: Welcart e-Commerce < 2.8.5 - Unauthenticated Arbitrary File Access
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
Description
The Welcart e-Commerce WordPress plugin before 2.8.5 does not validate user input before using it to output the content of a file, which could allow unauthenticated attacker to read arbitrary files on the server
Affected products
- Welcart e-Commerce: before 2.8.5 — fixed in 2.8.5
How to fix
Upgrade to a fixed version: Welcart e-Commerce 2.8.5. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/0d649a7e-3334-48f7-abca-fff0856e12c7
- https://wpscan.com/vulnerability/0d649a7e-3334-48f7-abca-fff0856e12c7
Get alerted when CVE-2022-4140 or the next vulnerability affects your stack