What’s Vulnerable › Vulnerabilities
CVE-2022-41409
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-07-18 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow vulnerability in pcre2test before 10.41 allows attackers to cause a denial of service or other unspecified impacts via negative input.
Affected products
- PCRE2: before 10.41 — fixed in 10.41
How to fix
Upgrade to a fixed version: PCRE2 10.41. Check the vendor advisory for mitigations.
References
- https://github.com/PCRE2Project/pcre2/commit/94e1c001761373b7d9450768aa15d04c25547a35
- https://github.com/PCRE2Project/pcre2/issues/141
- https://github.com/PCRE2Project/pcre2/commit/94e1c001761373b7d9450768aa15d04c25547a35
- https://github.com/PCRE2Project/pcre2/issues/141
Get alerted when CVE-2022-41409 or the next vulnerability affects your stack