What’s Vulnerable › Vulnerabilities
CVE-2022-4142: WordPress Filter Gallery Plugin < 0.1.6 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-02 · updated 2026-06-17
Description
The WordPress Filter Gallery Plugin WordPress plugin before 0.1.6 does not properly escape the filters passed in the ufg_gallery_filters ajax action before outputting them on the page, allowing a high privileged user such as an administrator to inject HTML or javascript to the plugin settings page, even when the unfiltered_html capability is disabled.
Affected products
- WordPress Filter Gallery Plugin: before 0.1.6 — fixed in 0.1.6
How to fix
Upgrade to a fixed version: WordPress Filter Gallery Plugin 0.1.6. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/8c2adadd-0684-49a8-9185-0c7d9581aef1
- https://wpscan.com/vulnerability/8c2adadd-0684-49a8-9185-0c7d9581aef1
Get alerted when CVE-2022-4142 or the next vulnerability affects your stack