What’s Vulnerable › Vulnerabilities
CVE-2022-4148: WP OAuth Server < 4.3.0 - Subscriber+ Arbitrary Client Deletion
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-03-20 · updated 2026-06-17
- Weakness: CWE-352
Description
The WP OAuth Server (OAuth Authentication) WordPress plugin before 4.3.0 has a flawed CSRF and authorisation check when deleting a client, which could allow any authenticated users, such as subscriber to delete arbitrary client.
Affected products
- Dash10 Oauth Server: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: Dash10 Oauth Server 4.3.0. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/be9b25c8-b0d7-4c22-81ff-e41650a4ed41
- https://wpscan.com/vulnerability/be9b25c8-b0d7-4c22-81ff-e41650a4ed41
Get alerted when CVE-2022-4148 or the next vulnerability affects your stack