What’s Vulnerable › Vulnerabilities

CVE-2022-41556

Description

A resource leak in gw_backend.c in lighttpd 1.4.56 through 1.4.66 could lead to a denial of service (connection-slot exhaustion) after a large amount of anomalous TCP behavior by clients. It is related to RDHUP mishandling in certain HTTP/1.1 chunked situations. Use of mod_fastcgi is, for example, affected. This is fixed in 1.4.67.

Affected products

How to fix

Upgrade to a fixed version: lighttpd 1.4.67. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-41556 or the next vulnerability affects your stack