What’s Vulnerable › Vulnerabilities
CVE-2022-4157: Contest Gallery < 19.1.5 - Admin+ SQL Injection
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-26 · updated 2026-06-17
Description
The Contest Gallery WordPress plugin before 19.1.5.1, Contest Gallery Pro WordPress plugin before 19.1.5.1 do not escape the cg_option_id POST parameter before concatenating it to an SQL query in export-votes-all.php. This may allow malicious users with administrator privileges (i.e. on multisite WordPress configurations) to leak sensitive information from the site's database.
Affected products
- Contest Gallery Pro: before 19.1.5.1 — fixed in 19.1.5.1
How to fix
Upgrade to a fixed version: Contest Gallery Pro 19.1.5.1. Check the vendor advisory for mitigations.
References
- https://bulletin.iese.de/post/contest-gallery_19-1-4-1_3
- https://wpscan.com/vulnerability/71feec63-67a5-482e-bf77-1396c306fae6
- https://bulletin.iese.de/post/contest-gallery_19-1-4-1_3
- https://wpscan.com/vulnerability/71feec63-67a5-482e-bf77-1396c306fae6
Get alerted when CVE-2022-4157 or the next vulnerability affects your stack