What’s Vulnerable › Vulnerabilities
CVE-2022-41604
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-27 · updated 2026-06-17
- Weakness: CWE-269
Description
Check Point ZoneAlarm Extreme Security before 15.8.211.19229 allows local users to escalate privileges. This occurs because of weak permissions for the %PROGRAMDATA%\CheckPoint\ZoneAlarm\Data\Updates directory, and a self-protection driver bypass that allows creation of a junction directory. This can be leveraged to perform an arbitrary file move as NT AUTHORITY\SYSTEM.
Affected products
- Check Point ZoneAlarm: before 15.8.211.19229 — fixed in 15.8.211.19229
How to fix
Upgrade to a fixed version: Check Point ZoneAlarm 15.8.211.19229. Check the vendor advisory for mitigations.
References
- https://github.com/Wh04m1001/ZoneAlarmEoP
- https://www.infigo.hr/en/insights/39/elevation-of-privilege-in-zonealarm-extreme-security/
- https://www.zonealarm.com/software/extreme-security/release-history
- https://github.com/Wh04m1001/ZoneAlarmEoP
- https://www.infigo.hr/en/insights/39/elevation-of-privilege-in-zonealarm-extreme-security/
- https://www.zonealarm.com/software/extreme-security/release-history
Get alerted when CVE-2022-41604 or the next vulnerability affects your stack