What’s Vulnerable › Vulnerabilities
CVE-2022-41678: Apache ActiveMQ: Insufficient API restrictions on Jolokia allow authenticated users to perform RCE
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 85.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-28 · updated 2026-06-17
- Weakness: CWE-287
Description
Once an user is authenticated on Jolokia, he can potentially trigger arbitrary code execution. In details, in ActiveMQ configurations, jetty allows org.jolokia.http.AgentServlet to handler request to /api/jolokia org.jolokia.http.HttpRequestHandler#handlePostRequest is able to create JmxRequest through JSONObject. And calls to org.jolokia.http.HttpRequestHandler#executeRequest. Into deeper calling stacks, org.jolokia.handler.ExecHandler#doHandleRequest can be invoked through refection. This could lead to RCE through via various mbeans. One example is unrestricted deserialization in jdk.management.jfr.FlightRecorderMXBeanImpl which exists on Java version above 11. 1 Call newRecording. 2 Call setConfiguration. And a webshell data hides in it. 3 Call startRecording. 4 Call copyTo method. The webshell will be written to a .jsp file. The mitigation is to restrict (by default) the actions authorized on Jolokia, or disable Jolokia. A more restrictive Jolokia configuration has been defined in default ActiveMQ distribution. We encourage users to upgrade to ActiveMQ distributions version including updated Jolokia configuration: 5.16.6, 5.17.4, 5.18.0, 6.0.0.
Affected products
- Apache ActiveMQ: before 5.16.6; from 5.17.0 before 5.17.4 — fixed in 5.16.6, 5.17.4
How to fix
Upgrade to a fixed version: Apache ActiveMQ 5.16.6, 5.17.4. Check the vendor advisory for mitigations.
References
- https://activemq.apache.org/security-advisories.data/CVE-2022-41678-announcement.txt
- https://lists.apache.org/thread/7g17kwbtjl011mm4tr8bn1vnoq9wh4sl
- https://security.netapp.com/advisory/ntap-20240216-0004/
- https://www.openwall.com/lists/oss-security/2023/11/28/1
- https://activemq.apache.org/security-advisories.data/CVE-2022-41678-announcement.txt
- https://lists.apache.org/thread/7g17kwbtjl011mm4tr8bn1vnoq9wh4sl
- https://lists.debian.org/debian-lts-announce/2024/10/msg00027.html
- https://security.netapp.com/advisory/ntap-20240216-0004/
- https://www.openwall.com/lists/oss-security/2023/11/28/1
Get alerted when CVE-2022-41678 or the next vulnerability affects your stack