What’s Vulnerable › Vulnerabilities
CVE-2022-41688
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-31 · updated 2026-06-17
- Weakness: CWE-306
Description
Delta Electronics InfraSuite Device Master versions 00.00.01a and prior lack proper authentication for functions that create and modify user groups. An attacker could provide malicious serialized objects that could run these functions without authentication to create a new user and add them to the administrator group.
Affected products
- Delta Electronics InfraSuite Device Master: before 00.00.02a — fixed in 00.00.02a
How to fix
Upgrade to a fixed version: Delta Electronics InfraSuite Device Master 00.00.02a. Check the vendor advisory for mitigations.
References
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-298-07
- https://www.cisa.gov/uscert/ics/advisories/icsa-22-298-07
Get alerted when CVE-2022-41688 or the next vulnerability affects your stack