What’s Vulnerable › Vulnerabilities
CVE-2022-4169: Theme and plugin translation for Polylang <= 3.2.16 - Missing Authorization
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-28 · updated 2026-06-17
- Weakness: CWE-862
Description
The Theme and plugin translation for Polylang is vulnerable to authorization bypass in versions up to, and including, 3.2.16 due to missing capability checks in the process_polylang_theme_translation_wp_loaded() function. This makes it possible for unauthenticated attackers to update plugin and theme translation settings and to import translation strings.
Affected products
- marcinkazmierski Theme and plugin translation for Polylang (TTfP): before 3.2.17 — fixed in 3.2.17
How to fix
Upgrade to a fixed version: marcinkazmierski Theme and plugin translation for Polylang (TTfP) 3.2.17. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2814605%40theme-translation-for-polylang%2Ftrunk&old=2812254%40theme-translation-for-polylang%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/9f6a358a-333c-4eb7-9149-348bf3713943?source=cve
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4169
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2814605%40theme-translation-for-polylang%2Ftrunk&old=2812254%40theme-translation-for-polylang%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/vulnerability-advisories-continued/#CVE-2022-4169
Get alerted when CVE-2022-4169 or the next vulnerability affects your stack