What’s Vulnerable › Vulnerabilities
CVE-2022-41853: Remote code execution in HyperSQL DataBase
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-10-06 · updated 2026-06-17
- Weakness: CWE-470
Description
Those using java.sql.Statement or java.sql.PreparedStatement in hsqldb (HyperSQL DataBase) to process untrusted input may be vulnerable to a remote code execution attack. By default it is allowed to call any static method of any Java class in the classpath resulting in code execution. The issue can be prevented by updating to 2.7.1 or by setting the system property "hsqldb.method_class_names" to classes which are allowed to be called. For example, System.setProperty("hsqldb.method_class_names", "abc") or Java argument -Dhsqldb.method_class_names="abc" can be used. From version 2.7.1 all classes by default are not accessible except those in java.lang.Math and need to be manually enabled.
Affected products
- Debian Linux: 10.0, 11.0
- Hsqldb Hypersql Database: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: Hsqldb Hypersql Database 2.7.1. Check the vendor advisory for mitigations.
References
- http://hsqldb.org/doc/2.0/guide/sqlroutines-chapt.html#src_jrt_access_control
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=50212#c7
- https://lists.debian.org/debian-lts-announce/2022/12/msg00020.html
- https://www.debian.org/security/2023/dsa-5313
- http://hsqldb.org/doc/2.0/guide/sqlroutines-chapt.html#src_jrt_access_control
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=50212#c7
- https://lists.debian.org/debian-lts-announce/2022/12/msg00020.html
- https://www.debian.org/security/2023/dsa-5313
Get alerted when CVE-2022-41853 or the next vulnerability affects your stack