What’s Vulnerable › Vulnerabilities
CVE-2022-41859
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-17 · updated 2026-06-17
- Weakness: CWE-200
Description
In freeradius, the EAP-PWD function compute_password_element() leaks information about the password which allows an attacker to substantially reduce the size of an offline dictionary attack.
Affected products
- freeradius: before 3.0.0 — fixed in 3.0.0
How to fix
Upgrade to a fixed version: freeradius 3.0.0. Check the vendor advisory for mitigations.
References
- https://freeradius.org/security/
- https://github.com/FreeRADIUS/freeradius-server/commit/9e5e8f2f
- https://freeradius.org/security/
- https://github.com/FreeRADIUS/freeradius-server/commit/9e5e8f2f
- https://lists.debian.org/debian-lts-announce/2025/06/msg00030.html
Get alerted when CVE-2022-41859 or the next vulnerability affects your stack