What’s Vulnerable › Vulnerabilities
CVE-2022-41862
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-03 · updated 2026-06-17
- Weakness: CWE-200
Description
In PostgreSQL, a modified, unauthenticated server can send an unterminated string during the establishment of Kerberos transport encryption. In certain conditions a server can cause a libpq client to over-read and report an error message containing uninitialized bytes.
Affected products
- Fedoraproject Fedora: 8
- PostgreSQL: from 12.0 before 12.14; from 13.0 before 13.10; from 14.0 before 14.7; from 15.0 before 15.2 — fixed in 12.14, 13.10, 14.7, 15.2
- Red Hat Enterprise Linux: 8.0
- RedHat Integration Camel K: all versions
- RedHat Integration Camel Quarkus: all versions
- RedHat Integration Service Registry: all versions
How to fix
Upgrade to a fixed version: PostgreSQL 12.14, 13.10, 14.7, 15.2. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2165722
- https://security.netapp.com/advisory/ntap-20230427-0002/
- https://www.postgresql.org/support/security/CVE-2022-41862/
- https://bugzilla.redhat.com/show_bug.cgi?id=2165722
- https://security.netapp.com/advisory/ntap-20230427-0002/
- https://www.postgresql.org/support/security/CVE-2022-41862/
Get alerted when CVE-2022-41862 or the next vulnerability affects your stack