What’s Vulnerable › Vulnerabilities
CVE-2022-41875: Remote Code Execution in Optica
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-502
Description
A remote code execution (RCE) vulnerability in Optica allows unauthenticated attackers to execute arbitrary code via specially crafted JSON payloads. Specially crafted JSON payloads may lead to RCE (remote code execution) on the attacked system running Optica. The vulnerability was patched in v. 0.10.2, where the call to the function `oj.load` was changed to `oj.safe_load`.
Affected products
- airbnb optica: before 0.10.2 — fixed in 0.10.2
How to fix
Upgrade to a fixed version: airbnb optica 0.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/airbnb/optica/security/advisories/GHSA-cf87-4h6x-phh6
- https://github.com/ohler55/oj/blob/develop/pages/Security.md
- https://www.rubydoc.info/gems/oj/3.0.2/Oj.safe_load
- https://github.com/airbnb/optica/security/advisories/GHSA-cf87-4h6x-phh6
- https://github.com/ohler55/oj/blob/develop/pages/Security.md
- https://www.rubydoc.info/gems/oj/3.0.2/Oj.safe_load
Get alerted when CVE-2022-41875 or the next vulnerability affects your stack