What’s Vulnerable › Vulnerabilities
CVE-2022-41878: Parse Server Prototype pollution and Injection via Cloud Code Webhooks or Cloud Code Triggers
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-10 · updated 2026-06-17
- Weakness: CWE-74
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. In versions prior to 5.3.2 or 4.10.19, keywords that are specified in the Parse Server option `requestKeywordDenylist` can be injected via Cloud Code Webhooks or Triggers. This will result in the keyword being saved to the database, bypassing the `requestKeywordDenylist` option. This issue is fixed in versions 4.10.19, and 5.3.2. If upgrade is not possible, the following Workarounds may be applied: Configure your firewall to only allow trusted servers to make request to the Parse Server Cloud Code Webhooks API, or block the API completely if you are not using the feature.
Affected products
- parse-community parse-server: before 4.10.19; from 5.0.0 before 5.3.2 — fixed in 4.10.19, 5.3.2
How to fix
Upgrade to a fixed version: parse-community parse-server 4.10.19, 5.3.2. Check the vendor advisory for mitigations.
References
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xprv-wvh7-qqqx
- https://github.com/parse-community/parse-server/security/advisories/GHSA-xprv-wvh7-qqqx
Get alerted when CVE-2022-41878 or the next vulnerability affects your stack