What’s Vulnerable › Vulnerabilities
CVE-2022-41881
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-12 · updated 2026-06-17
- Weakness: CWE-674
Description
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
Affected products
- Debian Linux: 10.0, 11.0
- netty: before 4.1.86 — fixed in 4.1.86
How to fix
Upgrade to a fixed version: netty 4.1.86. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/security/advisories/GHSA-fx2c-96vj-985v
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://security.netapp.com/advisory/ntap-20230113-0004/
- https://www.debian.org/security/2023/dsa-5316
- https://github.com/netty/netty/security/advisories/GHSA-fx2c-96vj-985v
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://security.netapp.com/advisory/ntap-20230113-0004/
- https://www.debian.org/security/2023/dsa-5316
Get alerted when CVE-2022-41881 or the next vulnerability affects your stack