What’s Vulnerable › Vulnerabilities
CVE-2022-41885: Overflow in `FusedResizeAndPadConv2D` in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-131
Description
TensorFlow is an open source platform for machine learning. When `tf.raw_ops.FusedResizeAndPadConv2D` is given a large tensor shape, it overflows. We have patched the issue in GitHub commit d66e1d568275e6a2947de97dca7a102a211e01ce. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.7.4; from 2.8.0 before 2.8.1; from 2.9.0 before 2.9.1; 2.10.0-rc0, 2.10.0-rc1, 2.10.0-rc2, 2.10.0-rc3 — fixed in 2.7.4, 2.8.1, 2.9.1
How to fix
Upgrade to a fixed version: tensorflow 2.7.4, 2.8.1, 2.9.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/conv_ops_fused_image_transform.cc
- https://github.com/tensorflow/tensorflow/commit/d66e1d568275e6a2947de97dca7a102a211e01ce
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-762h-vpvw-3rcx
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/conv_ops_fused_image_transform.cc
- https://github.com/tensorflow/tensorflow/commit/d66e1d568275e6a2947de97dca7a102a211e01ce
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-762h-vpvw-3rcx
Get alerted when CVE-2022-41885 or the next vulnerability affects your stack