What’s Vulnerable › Vulnerabilities
CVE-2022-41886: Overflow in `ImageProjectiveTransformV2` in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-131
Description
TensorFlow is an open source platform for machine learning. When `tf.raw_ops.ImageProjectiveTransformV2` is given a large output shape, it overflows. We have patched the issue in GitHub commit 8faa6ea692985dbe6ce10e1a3168e0bd60a723ba. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; 2.10.0 — fixed in 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/image/image_ops.cc
- https://github.com/tensorflow/tensorflow/commit/8faa6ea692985dbe6ce10e1a3168e0bd60a723ba
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-54pp-c6pp-7fpx
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/image/image_ops.cc
- https://github.com/tensorflow/tensorflow/commit/8faa6ea692985dbe6ce10e1a3168e0bd60a723ba
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-54pp-c6pp-7fpx
Get alerted when CVE-2022-41886 or the next vulnerability affects your stack