What’s Vulnerable › Vulnerabilities
CVE-2022-41891: Segfault in `tf.raw_ops.TensorListConcat` in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an open source platform for machine learning. If `tf.raw_ops.TensorListConcat` is given `element_shape=[]`, it results segmentation fault which can be used to trigger a denial of service attack. We have patched the issue in GitHub commit fc33f3dc4c14051a83eec6535b608abe1d355fde. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; from 2.10.0 before 2.10.1 — fixed in 2.10.1, 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.10.1, 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/list_kernels.h
- https://github.com/tensorflow/tensorflow/commit/fc33f3dc4c14051a83eec6535b608abe1d355fde
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-66vq-54fq-6jvv
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/list_kernels.h
- https://github.com/tensorflow/tensorflow/commit/fc33f3dc4c14051a83eec6535b608abe1d355fde
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-66vq-54fq-6jvv
Get alerted when CVE-2022-41891 or the next vulnerability affects your stack