What’s Vulnerable › Vulnerabilities
CVE-2022-41892: Arches vulnerable to SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-11 · updated 2026-06-17
- Weakness: CWE-89
Description
Arches is a web platform for creating, managing, & visualizing geospatial data. Versions prior to 6.1.2, 6.2.1, and 7.1.2 are vulnerable to SQL Injection. With a carefully crafted web request, it's possible to execute certain unwanted sql statements against the database. This issue is fixed in version 7.12, 6.2.1, and 6.1.2. Users are recommended to upgrade as soon as possible. There are no workarounds.
Affected products
- archesproject arches: through 6.1.1; 6.2.0, 7.0.0, 7.1.0, 7.1.1
References
- https://github.com/archesproject/arches/security/advisories/GHSA-gmpq-xrxj-xh8m
- https://github.com/archesproject/arches/security/advisories/GHSA-gmpq-xrxj-xh8m
Get alerted when CVE-2022-41892 or the next vulnerability affects your stack