What’s Vulnerable › Vulnerabilities
CVE-2022-41896: `tf.raw_ops.Mfcc` crashes in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an open source platform for machine learning. If `ThreadUnsafeUnigramCandidateSampler` is given input `filterbank_channel_count` greater than the allowed max size, TensorFlow will crash. We have patched the issue in GitHub commit 39ec7eaf1428e90c37787e5b3fbd68ebd3c48860. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; from 2.10.0 before 2.10.1 — fixed in 2.10.1, 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.10.1, 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/image/mirror_pad_op.cc
- https://github.com/tensorflow/tensorflow/commit/39ec7eaf1428e90c37787e5b3fbd68ebd3c48860
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rmg2-f698-wq35
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/image/mirror_pad_op.cc
- https://github.com/tensorflow/tensorflow/commit/39ec7eaf1428e90c37787e5b3fbd68ebd3c48860
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-rmg2-f698-wq35
Get alerted when CVE-2022-41896 or the next vulnerability affects your stack