What’s Vulnerable › Vulnerabilities
CVE-2022-41897: `FractionalMaxPoolGrad` Heap out of bounds read in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-125
Description
TensorFlow is an open source platform for machine learning. If `FractionMaxPoolGrad` is given outsize inputs `row_pooling_sequence` and `col_pooling_sequence`, TensorFlow will crash. We have patched the issue in GitHub commit d71090c3e5ca325bdf4b02eb236cfb3ee823e927. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; from 2.10.0 before 2.10.1 — fixed in 2.10.1, 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.10.1, 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/fractional_max_pool_op.cc
- https://github.com/tensorflow/tensorflow/commit/d71090c3e5ca325bdf4b02eb236cfb3ee823e927
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f2w8-jw48-fr7j
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/fractional_max_pool_op.cc
- https://github.com/tensorflow/tensorflow/commit/d71090c3e5ca325bdf4b02eb236cfb3ee823e927
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f2w8-jw48-fr7j
Get alerted when CVE-2022-41897 or the next vulnerability affects your stack