What’s Vulnerable › Vulnerabilities
CVE-2022-41898: `CHECK` fail via inputs in `SparseFillEmptyRowsGrad` in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an open source platform for machine learning. If `SparseFillEmptyRowsGrad` is given empty inputs, TensorFlow will crash. We have patched the issue in GitHub commit af4a6a3c8b95022c351edae94560acc61253a1b8. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; from 2.10.0 before 2.10.1 — fixed in 2.10.1, 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.10.1, 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/sparse_fill_empty_rows_op_gpu.cu.cc
- https://github.com/tensorflow/tensorflow/commit/af4a6a3c8b95022c351edae94560acc61253a1b8
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hq7g-wwwp-q46h
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/sparse_fill_empty_rows_op_gpu.cu.cc
- https://github.com/tensorflow/tensorflow/commit/af4a6a3c8b95022c351edae94560acc61253a1b8
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-hq7g-wwwp-q46h
Get alerted when CVE-2022-41898 or the next vulnerability affects your stack