What’s Vulnerable › Vulnerabilities
CVE-2022-41899: `CHECK` fail via inputs in `SdcaOptimizer` in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an open source platform for machine learning. Inputs `dense_features` or `example_state_data` not of rank 2 will trigger a `CHECK` fail in `SdcaOptimizer`. We have patched the issue in GitHub commit 80ff197d03db2a70c6a111f97dcdacad1b0babfa. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; 2.10.0 — fixed in 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/sdca_internal.cc
- https://github.com/tensorflow/tensorflow/commit/80ff197d03db2a70c6a111f97dcdacad1b0babfa
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-27rc-728f-x5w2
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/kernels/sdca_internal.cc
- https://github.com/tensorflow/tensorflow/commit/80ff197d03db2a70c6a111f97dcdacad1b0babfa
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-27rc-728f-x5w2
Get alerted when CVE-2022-41899 or the next vulnerability affects your stack