What’s Vulnerable › Vulnerabilities
CVE-2022-41902: Out of bounds write in grappler in Tensorflow
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-06 · updated 2026-06-17
- Weakness: CWE-787
Description
TensorFlow is an open source platform for machine learning. The function MakeGrapplerFunctionItem takes arguments that determine the sizes of inputs and outputs. If the inputs given are greater than or equal to the sizes of the outputs, an out-of-bounds memory read or a crash is triggered. We have patched the issue in GitHub commit a65411a1d69edfb16b25907ffb8f73556ce36bb7. The fix will be included in TensorFlow 2.11.0. We will also cherrypick this commit on TensorFlow 2.8.4, 2.9.3, and 2.10.1.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; 2.10.0 — fixed in 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/grappler/utils/functions.cc#L221
- https://github.com/tensorflow/tensorflow/commit/a65411a1d69edfb16b25907ffb8f73556ce36bb7
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cg88-rpvp-cjv5
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/core/grappler/utils/functions.cc#L221
- https://github.com/tensorflow/tensorflow/commit/a65411a1d69edfb16b25907ffb8f73556ce36bb7
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-cg88-rpvp-cjv5
Get alerted when CVE-2022-41902 or the next vulnerability affects your stack