What’s Vulnerable › Vulnerabilities
CVE-2022-41905: wsgidav is vulnerable to Cross-Site Scripting (XSS) when directory browsing is enabled
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-11 · updated 2026-06-17
- Weakness: CWE-79
Description
WsgiDAV is a generic and extendable WebDAV server based on WSGI. Implementations using this library with directory browsing enabled may be susceptible to Cross Site Scripting (XSS) attacks. This issue has been patched, users can upgrade to version 4.1.0. As a workaround, set `dir_browser.enable = False` in the configuration.
Affected products
- mar10 wsgidav: from 3.0.0 before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: mar10 wsgidav 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/mar10/wsgidav/commit/e9606ab0f42f4c1a6611bc3c52de299b0aba7726
- https://github.com/mar10/wsgidav/security/advisories/GHSA-xx6g-jj35-pxjv
- https://github.com/mar10/wsgidav/commit/e9606ab0f42f4c1a6611bc3c52de299b0aba7726
- https://github.com/mar10/wsgidav/security/advisories/GHSA-xx6g-jj35-pxjv
Get alerted when CVE-2022-41905 or the next vulnerability affects your stack