What’s Vulnerable › Vulnerabilities
CVE-2022-41906: OpenSearch Notifications is vulnerable to Server-Side Request Forgery (SSRF)
- Severity: high (CVSS 8.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-11 · updated 2026-06-17
- Weakness: CWE-918
Description
OpenSearch Notifications is a notifications plugin for OpenSearch that enables other plugins to send notifications via Email, Slack, Amazon Chime, Custom web-hook etc channels. A potential SSRF issue in OpenSearch Notifications Plugin starting in 2.0.0 and prior to 2.2.1 could allow an existing privileged user to enumerate listening services or interact with configured resources via HTTP requests exceeding the Notification plugin's intended scope. OpenSearch 2.2.1+ contains the fix for this issue. There are currently no recommended workarounds.
Affected products
- opensearch-project notifications: before 2.2.1.0 — fixed in 2.2.1.0
How to fix
Upgrade to a fixed version: opensearch-project notifications 2.2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/opensearch-project/notifications/pull/496
- https://github.com/opensearch-project/notifications/pull/507
- https://github.com/opensearch-project/notifications/security/advisories/GHSA-pfc4-3436-jgrw
- https://github.com/opensearch-project/notifications/pull/496
- https://github.com/opensearch-project/notifications/pull/507
- https://github.com/opensearch-project/notifications/security/advisories/GHSA-pfc4-3436-jgrw
Get alerted when CVE-2022-41906 or the next vulnerability affects your stack