What’s Vulnerable › Vulnerabilities
CVE-2022-41908: `CHECK` fail via inputs in `PyFunc` in Tensorflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-18 · updated 2026-06-17
- Weakness: CWE-20
Description
TensorFlow is an open source platform for machine learning. An input `token` that is not a UTF-8 bytestring will trigger a `CHECK` fail in `tf.raw_ops.PyFunc`. We have patched the issue in GitHub commit 9f03a9d3bafe902c1e6beb105b2f24172f238645. The fix will be included in TensorFlow 2.11. We will also cherrypick this commit on TensorFlow 2.10.1, 2.9.3, and TensorFlow 2.8.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.8.4; from 2.9.0 before 2.9.3; 2.10.0 — fixed in 2.8.4, 2.9.3
How to fix
Upgrade to a fixed version: tensorflow 2.8.4, 2.9.3. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/python/lib/core/py_func.cc
- https://github.com/tensorflow/tensorflow/commit/9f03a9d3bafe902c1e6beb105b2f24172f238645
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mv77-9g28-cwg3
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/python/lib/core/py_func.cc
- https://github.com/tensorflow/tensorflow/commit/9f03a9d3bafe902c1e6beb105b2f24172f238645
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-mv77-9g28-cwg3
Get alerted when CVE-2022-41908 or the next vulnerability affects your stack