What’s Vulnerable › Vulnerabilities
CVE-2022-41915
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-13 · updated 2026-06-17
- Weakness: CWE-113
Description
Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.
Affected products
- Debian Linux: 10.0, 11.0
- netty: from 4.1.83 before 4.1.86 — fixed in 4.1.86
How to fix
Upgrade to a fixed version: netty 4.1.86. Check the vendor advisory for mitigations.
References
- https://github.com/netty/netty/commit/fe18adff1c2b333acb135ab779a3b9ba3295a1c4
- https://github.com/netty/netty/issues/13084
- https://github.com/netty/netty/pull/12760
- https://github.com/netty/netty/security/advisories/GHSA-hh82-3pmq-7frp
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
- https://security.netapp.com/advisory/ntap-20230113-0004/
- https://www.debian.org/security/2023/dsa-5316
- https://github.com/netty/netty/commit/fe18adff1c2b333acb135ab779a3b9ba3295a1c4
- https://github.com/netty/netty/issues/13084
- https://github.com/netty/netty/pull/12760
- https://github.com/netty/netty/security/advisories/GHSA-hh82-3pmq-7frp
- https://lists.debian.org/debian-lts-announce/2023/01/msg00008.html
Get alerted when CVE-2022-41915 or the next vulnerability affects your stack