What’s Vulnerable › Vulnerabilities
CVE-2022-41916: Read one byte past a buffer when normalizing Unicode
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-15 · updated 2026-06-17
- Weakness: CWE-193
Description
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
Affected products
- Debian Linux: 10.0, 11.0
- Heimdal Software Kerberos: before 7.7.1 — fixed in 7.7.1
How to fix
Upgrade to a fixed version: Heimdal Software Kerberos 7.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
- https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
- https://security.gentoo.org/glsa/202310-06
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://www.debian.org/security/2022/dsa-5287
- https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
- https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
- https://security.gentoo.org/glsa/202310-06
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://www.debian.org/security/2022/dsa-5287
Get alerted when CVE-2022-41916 or the next vulnerability affects your stack