What’s Vulnerable › Vulnerabilities
CVE-2022-41917: Incorrect Error Handling Allowed Partial File Reads Over REST API in OpenSearch
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-16 · updated 2026-06-17
- Weakness: CWE-200
Description
OpenSearch is a community-driven, open source fork of Elasticsearch and Kibana. OpenSearch allows users to specify a local file when defining text analyzers to process data for text analysis. An issue in the implementation of this feature allows certain specially crafted queries to return a response containing the first line of text from arbitrary files. The list of potentially impacted files is limited to text files with read permissions allowed in the Java Security Manager policy configuration. OpenSearch version 1.3.7 and 2.4.0 contain a fix for this issue. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- AWS Opensearch: from 1.0.0 before 1.3.7; from 2.0.0 before 2.4.0 — fixed in 1.3.7, 2.4.0
How to fix
Upgrade to a fixed version: AWS Opensearch 1.3.7, 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/opensearch-project/OpenSearch/commit/6d20423f5920745463b1abc5f1daf6a786c41aa0
- https://github.com/opensearch-project/OpenSearch/security/advisories/GHSA-w3rx-m34v-wrqx
- https://github.com/opensearch-project/OpenSearch/commit/6d20423f5920745463b1abc5f1daf6a786c41aa0
- https://github.com/opensearch-project/OpenSearch/security/advisories/GHSA-w3rx-m34v-wrqx
Get alerted when CVE-2022-41917 or the next vulnerability affects your stack