What’s Vulnerable › Vulnerabilities
CVE-2022-41918: Issue with fine-grained access control of indices backing data streams
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-15 · updated 2026-06-17
- Weakness: CWE-612
Description
OpenSearch is a community-driven, open source fork of Elasticsearch and Kibana. There is an issue with the implementation of fine-grained access control rules (document-level security, field-level security and field masking) where they are not correctly applied to the indices that back data streams potentially leading to incorrect access authorization. OpenSearch 1.3.7 and 2.4.0 contain a fix for this issue. Users are advised to update. There are no known workarounds for this issue.
Affected products
- AWS Opensearch: before 1.3.7; from 2.0.0 before 2.4.0 — fixed in 1.3.7, 2.4.0
How to fix
Upgrade to a fixed version: AWS Opensearch 1.3.7, 2.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/opensearch-project/security/commit/f7cc569c9d3fa5d5432c76c854eed280d45ce6f4
- https://github.com/opensearch-project/security/security/advisories/GHSA-wmx7-x4jp-9jgg
- https://github.com/opensearch-project/security/commit/f7cc569c9d3fa5d5432c76c854eed280d45ce6f4
- https://github.com/opensearch-project/security/security/advisories/GHSA-wmx7-x4jp-9jgg
Get alerted when CVE-2022-41918 or the next vulnerability affects your stack