What’s Vulnerable › Vulnerabilities
CVE-2022-41919: Fastify vulnerable to Cross-Site Request Forgery (CSRF) attack via incorrect content type
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-22 · updated 2026-06-17
- Weakness: CWE-352
Description
Fastify is a web framework with minimal overhead and plugin architecture. The attacker can use the incorrect `Content-Type` to bypass the `Pre-Flight` checking of `fetch`. `fetch()` requests with Content-Type’s essence as "application/x-www-form-urlencoded", "multipart/form-data", or "text/plain", could potentially be used to invoke routes that only accepts `application/json` content type, thus bypassing any CORS protection, and therefore they could lead to a Cross-Site Request Forgery attack. This issue has been patched in version 4.10.2 and 3.29.4. As a workaround, implement Cross-Site Request Forgery protection using `@fastify/csrf'.
Affected products
- fastify: from 3.0.0 before 3.29.4; from 4.0.0 before 4.10.2 — fixed in 3.29.4, 4.10.2
How to fix
Upgrade to a fixed version: fastify 3.29.4, 4.10.2. Check the vendor advisory for mitigations.
References
- https://github.com/fastify/fastify/commit/62dde76f1f7aca76e38625fe8d983761f26e6fc9
- https://github.com/fastify/fastify/security/advisories/GHSA-3fjj-p79j-c9hh
- https://www.npmjs.com/package/%40fastify/csrf
- https://github.com/fastify/fastify/commit/62dde76f1f7aca76e38625fe8d983761f26e6fc9
- https://github.com/fastify/fastify/security/advisories/GHSA-3fjj-p79j-c9hh
- https://www.npmjs.com/package/%40fastify/csrf
Get alerted when CVE-2022-41919 or the next vulnerability affects your stack