What’s Vulnerable › Vulnerabilities
CVE-2022-41920: Zip slip in Lancet
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-17 · updated 2026-06-17
- Weakness: CWE-22
Description
Lancet is a general utility library for the go programming language. Affected versions are subject to a ZipSlip issue when using the fileutil package to unzip files. This issue has been addressed and a fix will be included in versions 2.1.10 and 1.3.4. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- duke-git lancet: before 1.3.4; from 2.0.0 before 2.1.10 — fixed in 1.3.4, 2.1.10
How to fix
Upgrade to a fixed version: duke-git lancet 1.3.4, 2.1.10. Check the vendor advisory for mitigations.
References
- https://github.com/duke-git/lancet/commit/f133b32faa05eb93e66175d01827afa4b7094572
- https://github.com/duke-git/lancet/commit/f869a0a67098e92d24ddd913e188b32404fa72c9
- https://github.com/duke-git/lancet/issues/62
- https://github.com/duke-git/lancet/security/advisories/GHSA-pp3f-xrw5-q5j4
- https://github.com/duke-git/lancet/commit/f133b32faa05eb93e66175d01827afa4b7094572
- https://github.com/duke-git/lancet/commit/f869a0a67098e92d24ddd913e188b32404fa72c9
- https://github.com/duke-git/lancet/issues/62
- https://github.com/duke-git/lancet/security/advisories/GHSA-pp3f-xrw5-q5j4
Get alerted when CVE-2022-41920 or the next vulnerability affects your stack