What’s Vulnerable › Vulnerabilities
CVE-2022-41921: Discourse chat messages should have a maximum character limit
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Discourse is an open-source discussion platform. Prior to version 2.9.0.beta13, users can post chat messages of an unlimited length, which can cause a denial of service for other users when posting huge amounts of text. Users should upgrade to version 2.9.0.beta13, where a limit has been introduced. No known workarounds are available.
Affected products
- discourse: before 2.9.0; 2.9.0-beta1, 2.9.0-beta10, 2.9.0-beta11, 2.9.0-beta12, 2.9.0-beta2, 2.9.0-beta3 (+6) — fixed in 2.9.0
How to fix
Upgrade to a fixed version: discourse 2.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/3de765c89524a526ce611e11468d758a471a933f
- https://github.com/discourse/discourse/security/advisories/GHSA-mfh7-6cv6-qccc
- https://github.com/discourse/discourse/commit/3de765c89524a526ce611e11468d758a471a933f
- https://github.com/discourse/discourse/security/advisories/GHSA-mfh7-6cv6-qccc
Get alerted when CVE-2022-41921 or the next vulnerability affects your stack