What’s Vulnerable › Vulnerabilities
CVE-2022-41922: yiisoft/yii before v1.1.27 vulnerable to Remote Code Execution if the application calls `unserialize()` on arbitrary user input
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-502
Description
`yiisoft/yii` before version 1.1.27 are vulnerable to Remote Code Execution (RCE) if the application calls `unserialize()` on arbitrary user input. This has been patched in 1.1.27.
Affected products
- yiisoft yii: before 1.1.27 — fixed in 1.1.27
How to fix
Upgrade to a fixed version: yiisoft yii 1.1.27. Check the vendor advisory for mitigations.
References
- https://github.com/yiisoft/yii/commit/ed67b7cc57216557c5c595c6650cdd2d3aa41c52
- https://github.com/yiisoft/yii/security/advisories/GHSA-442f-wcwq-fpcf
- https://github.com/yiisoft/yii/commit/ed67b7cc57216557c5c595c6650cdd2d3aa41c52
- https://github.com/yiisoft/yii/security/advisories/GHSA-442f-wcwq-fpcf
Get alerted when CVE-2022-41922 or the next vulnerability affects your stack