What’s Vulnerable › Vulnerabilities
CVE-2022-41925: Tailscale daemon is vulnerable to information disclosure via CSRF
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-352
Description
A vulnerability identified in the Tailscale client allows a malicious website to access the peer API, which can then be used to access Tailscale environment variables. In the Tailscale client, the peer API was vulnerable to DNS rebinding. This allowed an attacker-controlled website visited by the node to rebind DNS for the peer API to an attacker-controlled DNS server, and then making peer API requests in the client, including accessing the node’s Tailscale environment variables. An attacker with access to the peer API on a node could use that access to read the node’s environment variables, including any credentials or secrets stored in environment variables. This may include Tailscale authentication keys, which could then be used to add new nodes to the user’s tailnet. The peer API access could also be used to learn of other nodes in the tailnet or send files via Taildrop. All Tailscale clients prior to version v1.32.3 are affected. Upgrade to v1.32.3 or later to remediate the issue.
Affected products
- tailscale: before 1.32.3 — fixed in 1.32.3
How to fix
Upgrade to a fixed version: tailscale 1.32.3. Check the vendor advisory for mitigations.
References
- https://emily.id.au/tailscale
- https://github.com/tailscale/tailscale/security/advisories/GHSA-qccm-wmcq-pwr6
- https://tailscale.com/security-bulletins/#ts-2022-005
- https://emily.id.au/tailscale
- https://github.com/tailscale/tailscale/security/advisories/GHSA-qccm-wmcq-pwr6
- https://tailscale.com/security-bulletins/#ts-2022-005
Get alerted when CVE-2022-41925 or the next vulnerability affects your stack