What’s Vulnerable › Vulnerabilities
CVE-2022-41927: XWiki Platform vulnerable to Cross-Site Request Forgery (CSRF) allowing to delete or rename tags
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-23 · updated 2026-06-17
- Weakness: CWE-352
Description
XWiki Platform is vulnerable to Cross-Site Request Forgery (CSRF) that may allow attackers to delete or rename tags without needing any confirmation. The problem has been patched in XWiki 13.10.7, 14.4.1 and 14.5RC1. Workarounds: It's possible to patch existing instances directly by editing the page Main.Tags and add this kind of check, in the code for renaming and for deleting: ``` #if (!$services.csrf.isTokenValid($request.get('form_token'))) #set ($discard = $response.sendError(401, "Wrong CSRF token")) #end ```
Affected products
- xwiki-platform: from 3.2 (excl.) before 13.10.7; 3.2-milestone2, 3.2-milestone3, 14.4 — fixed in 13.10.7
How to fix
Upgrade to a fixed version: xwiki-platform 13.10.7. Check the vendor advisory for mitigations.
References
- https://github.com/xwiki/xwiki-platform/commit/7fd4cda0590180c4d34f557597e9e10e263def9e
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-mq7h-5574-hw9f
- https://github.com/xwiki/xwiki-platform/commit/7fd4cda0590180c4d34f557597e9e10e263def9e
- https://github.com/xwiki/xwiki-platform/security/advisories/GHSA-mq7h-5574-hw9f
Get alerted when CVE-2022-41927 or the next vulnerability affects your stack