What’s Vulnerable › Vulnerabilities
CVE-2022-41938: Cross site scripting vulnerability with discussion titles in flarum
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Flarum is an open source discussion platform. Flarum's page title system allowed for page titles to be converted into HTML DOM nodes when pages were rendered. The change was made after `v1.5` and was not noticed. This allowed an attacker to inject malicious HTML markup using a discussion title input, either by creating a new discussion or renaming one. The XSS attack occurs after a visitor opens the relevant discussion page. All communities running Flarum from `v1.5.0` to `v1.6.1` are impacted. The vulnerability has been fixed and published as flarum/core `v1.6.2`. All communities running Flarum from `v1.5.0` to `v1.6.1` have to upgrade as soon as possible to v1.6.2. There are no known workarounds for this issue.
Affected products
- Flarum: from 1.5.0 before 1.6.2 — fixed in 1.6.2
How to fix
Upgrade to a fixed version: Flarum 1.6.2. Check the vendor advisory for mitigations.
References
- https://discuss.flarum.org/d/27558
- https://github.com/flarum/framework/commit/690de9ce0ffe7ac4d45b73e303f44340c3433138
- https://github.com/flarum/framework/security/advisories/GHSA-7x4w-j98p-854x
- https://discuss.flarum.org/d/27558
- https://github.com/flarum/framework/commit/690de9ce0ffe7ac4d45b73e303f44340c3433138
- https://github.com/flarum/framework/security/advisories/GHSA-7x4w-j98p-854x
Get alerted when CVE-2022-41938 or the next vulnerability affects your stack