What’s Vulnerable › Vulnerabilities
CVE-2022-41939: Credential exposure when running third-party builders in knative/func
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-19 · updated 2026-06-17
- Weakness: CWE-200
Description
knative.dev/func is is a client library and CLI enabling the development and deployment of Kubernetes functions. Developers using a malicious or compromised third-party buildpack could expose their registry credentials or local docker socket to a malicious `lifecycle` container. This issues has been patched in PR #1442, and is part of release 1.8.1. This issue only affects users who are using function buildpacks from third-parties; pinning the builder image to a specific content-hash with a valid `lifecycle` image will also mitigate the attack.
Affected products
- knative func: before 1.8.1 — fixed in 1.8.1
How to fix
Upgrade to a fixed version: knative func 1.8.1. Check the vendor advisory for mitigations.
References
- https://github.com/knative/func/blob/5ca77d38744d3481cc0b795f607c5859b19588fc/buildpacks/builder.go#L37-L41
- https://github.com/knative/func/pull/1442
- https://github.com/knative/func/releases/tag/knative-v1.8.1
- https://github.com/knative/func/security/advisories/GHSA-5336-2g3f-9g3m
- https://github.com/knative/func/blob/5ca77d38744d3481cc0b795f607c5859b19588fc/buildpacks/builder.go#L37-L41
- https://github.com/knative/func/pull/1442
- https://github.com/knative/func/releases/tag/knative-v1.8.1
- https://github.com/knative/func/security/advisories/GHSA-5336-2g3f-9g3m
Get alerted when CVE-2022-41939 or the next vulnerability affects your stack