What’s Vulnerable › Vulnerabilities
CVE-2022-41942: Sourcegraph vulnerable to Comand Injection via gitserver
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-22 · updated 2026-06-17
- Weakness: CWE-20
Description
Sourcegraph is a code intelligence platform. In versions prior to 4.1.0 a command Injection vulnerability existed in the gitserver service, present in all Sourcegraph deployments. This vulnerability was caused by a lack of input validation on the host parameter of the `/list-gitolite` endpoint. It was possible to send a crafted request to gitserver that would execute commands inside the container. Successful exploitation requires the ability to send local requests to gitserver. The issue is patched in version 4.1.0.
Affected products
- sourcegraph: before 4.1.0 — fixed in 4.1.0
How to fix
Upgrade to a fixed version: sourcegraph 4.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/sourcegraph/sourcegraph/pull/42553
- https://github.com/sourcegraph/sourcegraph/security/advisories/GHSA-pfm3-23mh-6xjp
- https://github.com/sourcegraph/sourcegraph/pull/42553
- https://github.com/sourcegraph/sourcegraph/security/advisories/GHSA-pfm3-23mh-6xjp
Get alerted when CVE-2022-41942 or the next vulnerability affects your stack