What’s Vulnerable › Vulnerabilities
CVE-2022-41947: Cross-site Scripting with user-uploaded files in dhis2-core
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-08 · updated 2026-06-17
- Weakness: CWE-79
Description
DHIS 2 is an open source information system for data capture, management, validation, analytics and visualization. Through various features of DHIS2, an authenticated user may be able to upload a file which includes embedded javascript. The user could then potentially trick another authenticated user to open the malicious file in a browser which would trigger the javascript code, resulting in a cross-site scripting (XSS) attack. DHIS2 administrators should upgrade to the following hotfix releases: 2.36.12.1, 2.37.8.1, 2.38.2.1, 2.39.0.1. Users unable to upgrade may add the following simple CSP rule in your web proxy to the vulnerable endpoints: `script-src 'none'`. This workaround will prevent all javascript from running on those endpoints.
Affected products
- dhis2-core: from 2.35.0 before 2.36.12.1; from 2.37.0 before 2.37.8.1; from 2.38.0 before 2.38.2.1; 2.39.0 — fixed in 2.36.12.1, 2.37.8.1, 2.38.2.1
How to fix
Upgrade to a fixed version: dhis2-core 2.36.12.1, 2.37.8.1, 2.38.2.1. Check the vendor advisory for mitigations.
References
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP
- https://github.com/dhis2/dhis2-core/security/advisories/GHSA-763w-rm78-6xcg
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP
- https://github.com/dhis2/dhis2-core/security/advisories/GHSA-763w-rm78-6xcg
Get alerted when CVE-2022-41947 or the next vulnerability affects your stack