What’s Vulnerable › Vulnerabilities
CVE-2022-41958: Deserialization Vulnerability by yaml config input in super-xray
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-11-25 · updated 2026-06-17
- Weakness: CWE-502
Description
super-xray is a web vulnerability scanning tool. Versions prior to 0.7 assumed trusted input for the program config which is stored in a yaml file. An attacker with local access to the file could exploit this and compromise the program. This issue has been addressed in commit `4d0d5966` and will be included in future releases. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- 4ra1n super-xray: before 0.7 — fixed in 0.7
How to fix
Upgrade to a fixed version: 4ra1n super-xray 0.7. Check the vendor advisory for mitigations.
References
- https://github.com/4ra1n/super-xray/commit/4d0d59663596db03f39d7edd2be251d48b52dcfc
- https://github.com/4ra1n/super-xray/security/advisories/GHSA-39pv-4vmj-c4fr
- https://github.com/4ra1n/super-xray/commit/4d0d59663596db03f39d7edd2be251d48b52dcfc
- https://github.com/4ra1n/super-xray/security/advisories/GHSA-39pv-4vmj-c4fr
Get alerted when CVE-2022-41958 or the next vulnerability affects your stack