What’s Vulnerable › Vulnerabilities

CVE-2022-41974

Description

multipath-tools 0.7.0 through 0.9.x before 0.9.2 allows local users to obtain root access, as exploited alone or in conjunction with CVE-2022-41973. Local users able to write to UNIX domain sockets can bypass access controls and manipulate the multipath setup. This can lead to local privilege escalation to root. This occurs because an attacker can repeat a keyword, which is mishandled because arithmetic ADD is used instead of bitwise OR.

Affected products

How to fix

Upgrade to a fixed version: Opensvc Multipath-Tools 0.9.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-41974 or the next vulnerability affects your stack