What’s Vulnerable › Vulnerabilities
CVE-2022-4199: Link Library < 7.4.1 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-01-16 · updated 2026-06-17
Description
The Link Library WordPress plugin before 7.4.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- Link Library: before 7.4.1 — fixed in 7.4.1
How to fix
Upgrade to a fixed version: Link Library 7.4.1. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/c4688c0b-0538-4151-995c-d437d7e4829d
- https://wpscan.com/vulnerability/c4688c0b-0538-4151-995c-d437d7e4829d
Get alerted when CVE-2022-4199 or the next vulnerability affects your stack