What’s Vulnerable › Vulnerabilities
CVE-2022-42001: Potential XSS in book navigation
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-11-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) vulnerability in BlueSpiceBookshelf extension of BlueSpice allows user with regular account and edit permissions to inject arbitrary HTML into the book navigation.
Affected products
- Hallo Welt! GmbH BlueSpice: from 4.1.0 before 4.2.1 — fixed in 4.2.1
How to fix
Upgrade to a fixed version: Hallo Welt! GmbH BlueSpice 4.2.1. Check the vendor advisory for mitigations.
References
- https://en.wiki.bluespice.com/wiki/Security:Security_Advisories/BSSA-2022-05
- https://en.wiki.bluespice.com/wiki/Security:Security_Advisories/BSSA-2022-05
Get alerted when CVE-2022-42001 or the next vulnerability affects your stack