What’s Vulnerable › Vulnerabilities
CVE-2022-42009: Apache Ambari: A malicious authenticated user can remotely execute arbitrary code in the context of the application.
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-07-12 · updated 2026-06-17
- Weakness: CWE-917
Description
SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.
Affected products
- Apache Software Foundation Apache Ambari: from 2.7.0 before 2.7.7 — fixed in 2.7.7
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Ambari 2.7.7. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/6xf477ttz1oxmg0bx0tpdoz2mlqd7sbc
- https://lists.apache.org/thread/6xf477ttz1oxmg0bx0tpdoz2mlqd7sbc
Get alerted when CVE-2022-42009 or the next vulnerability affects your stack