What’s Vulnerable › Vulnerabilities

CVE-2022-42011

Description

An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash when receiving a message where an array length is inconsistent with the size of the element type.

Affected products

How to fix

Upgrade to a fixed version: Freedesktop Dbus 1.12.24, 1.14.4, 1.15.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-42011 or the next vulnerability affects your stack