What’s Vulnerable › Vulnerabilities
CVE-2022-42012
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-10-10 · updated 2026-06-17
- Weakness: CWE-20
Description
An issue was discovered in D-Bus before 1.12.24, 1.13.x and 1.14.x before 1.14.4, and 1.15.x before 1.15.2. An authenticated attacker can cause dbus-daemon and other programs that use libdbus to crash by sending a message with attached file descriptors in an unexpected format.
Affected products
- Fedoraproject Fedora: 35, 36, 37
- Freedesktop Dbus: before 1.12.24; from 1.13.0 before 1.14.4; from 1.15.0 before 1.15.2 — fixed in 1.12.24, 1.14.4, 1.15.2
How to fix
Upgrade to a fixed version: Freedesktop Dbus 1.12.24, 1.14.4, 1.15.2. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/dbus/dbus/-/issues/417
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/E4CO7N226I3X5FNBR2MACCH6TS764VJP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ND74SKN56BCYL3QLEAAB6E64UUBRA5UG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SQCSLMCK2XGX23R2DKW2MSAICQAK6MT2/
- https://security.gentoo.org/glsa/202305-08
- https://www.openwall.com/lists/oss-security/2022/10/06/1
- https://gitlab.freedesktop.org/dbus/dbus/-/issues/417
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/E4CO7N226I3X5FNBR2MACCH6TS764VJP/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ND74SKN56BCYL3QLEAAB6E64UUBRA5UG/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/SQCSLMCK2XGX23R2DKW2MSAICQAK6MT2/
- https://security.gentoo.org/glsa/202305-08
- https://www.openwall.com/lists/oss-security/2022/10/06/1
Get alerted when CVE-2022-42012 or the next vulnerability affects your stack