What’s Vulnerable › Vulnerabilities

CVE-2022-42114

Description

A Cross-site scripting (XSS) vulnerability in the Role module's edit role assignees page in Liferay Portal 7.4.0 through 7.4.3.36, and Liferay DXP 7.4 before update 37 allows remote attackers to inject arbitrary web script or HTML.

Affected products

How to fix

Upgrade to a fixed version: Liferay DXP 7.4; Liferay Portal 7.4.3.37. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2022-42114 or the next vulnerability affects your stack